查看: 28|回复: 3

RK3572 的 RKNPU3 驱动 v1.0.1 单次 dma_map_sgtable 超过约 1GB 返回 -12

1

主题

2

回帖

6

积分

isms_zkniNKWb 发表于 前天 15:54 | 显示全部楼层 |阅读模式
RK3572 的 RKNPU3 驱动 v1.0.1 单次 dma_map_sgtable 超过约 1GB 返回 -12,有没有新版本驱动可让单次 dma_map_sgtable 超过约 1GB???
回复

使用道具 举报

1

主题

2

回帖

6

积分

楼主| isms_zkniNKWb 发表于 前天 15:56 | 显示全部楼层
@飞凌-unix   @飞凌-marketing  @飞凌-fatfish  @飞凌-alexlee  有没有新版本驱动可让单次 dma_map_sgtable 超过约 1GB???

点评

您这边可以提供详细的问题复现方法吗,这边排查下问题  详情 回复 发表于 前天 17:46
回复 支持 反对

使用道具 举报

0

主题

1

回帖

9

积分

xiaoxiaozhu0001 发表于 前天 17:46 | 显示全部楼层
isms_zkniNKWb 发表于 2026-10-8 15:56
@飞凌-unix   @飞凌-marketing  @飞凌-fatfish  @飞凌-alexlee  有没有新版本驱动可让单次 dma_map_sgtable ...

您这边可以提供详细的问题复现方法吗,这边排查下问题
回复 支持 反对

使用道具 举报

1

主题

2

回帖

6

积分

楼主| isms_zkniNKWb 发表于 昨天 14:17 | 显示全部楼层
在开发板上面部署 Qwen3.5-2B 时,启动失败,但是Qwen2.5-1.5B 可以正常使用。可以在开发板上面试一下。板端内核驱动 RKNPU3是v1.0.1,在载入模型时,参数会超过1GB , 单次 DMA 映射约 1GB 就报 -12
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则