查看: 21459|回复: 4

[Linux] A40i千兆以太网无法up,内核日志打印“Initialize hardware error”

2

主题

3

回帖

18

积分

A40i\T3\T507\T527通行证i.MX RT通行证

lss1330 发表于 2022-3-11 21:36:53 | 显示全部楼层 |阅读模式
本帖最后由 lss1330 于 2022-3-11 21:39 编辑

使用ifconfig 配置网卡地址时无法启动,查看系统日志显示硬件初始化失败。 Snipaste_2022-03-11_21-38-29.png

跟踪log到驱动,是mac复位失败导致的,mac是在soc里的,感觉吴姐鸭。
Snipaste_2022-03-11_21-37-33.png
请问哪位大神有遇到过这个问题吗,求赐教~


回复

使用道具 举报

0

主题

1185

回帖

2207

积分

FCU1501通行证

zhichao 发表于 2022-3-12 10:45:58 | 显示全部楼层
您是参考我们的方案配置的引脚和驱动吗,正常的修改驱动是直接替换的,驱动本身不会有问题,软件上容易有问题的点就是引脚配置,初始化引脚我们是没有使用的,初始化过程是硬件控制的,一般来说您这个应该检查一下硬件,看看物料和焊接有没有问题

点评

恩恩,设计上是参考你们方案的引脚的,驱动没有修改过,是贵司提供的源码直接编译的。 MAC是soc内部的以太网控制器,目前是复位mac失败,这个操作应该跟外设没有关系才对?  详情 回复 发表于 2022-3-14 11:00
点评回复 支持 反对

使用道具 举报

2

主题

3

回帖

18

积分

A40i\T3\T507\T527通行证i.MX RT通行证

楼主| lss1330 发表于 2022-3-14 11:00:17 | 显示全部楼层
zhichao 发表于 2022-3-12 10:45
您是参考我们的方案配置的引脚和驱动吗,正常的修改驱动是直接替换的,驱动本身不会有问题,软件上容易有问 ...

恩恩,设计上是参考你们方案的引脚的,驱动没有修改过,是贵司提供的源码直接编译的。
MAC是soc内部的以太网控制器,目前是复位mac失败,这个操作应该跟外设没有关系才对?
点评回复 支持 反对

使用道具 举报

0

主题

1185

回帖

2207

积分

FCU1501通行证

zhichao 发表于 2022-3-14 11:38:49 | 显示全部楼层
我们双网口方案中千兆网口是提供驱动的,一般是AR8031或yt8521芯片。驱动大体差异不大,只有细微修改。您这个复位失败可以看看能不能识别mdio,能识别就看看硬件哪有问题
点评回复 支持 反对

使用道具 举报

0

主题

158

回帖

385

积分

LS1012A通行证LS1043A\46A通行证A40i\T3\T507\T527通行证i.MX8MM通行证RK3399通行证LS1028A通行证AM5718通行证Hi3519A通行证AM335x通行证i.MX6UL通行证i.MX RT通行证i.MX6Q通行证XX18通行证TCU通行证FDU产品通行证FCU1401通行证FCU1301通行证FCU11xx通行证FCU1201通行证FCU2301\FCU2302通行证FCU2401通行证5G转接卡通行证

tanglu 发表于 2022-3-14 16:12:31 | 显示全部楼层
您现在用的phy芯片和我们给您提供的双网口扩展方案里的phy芯片一样吗?您使用的phy是哪两个?
点评回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则